Post

0 followers Follow
0
Avatar

The save method is broken

When I call beePluginInstance.save() the onSave callback is not called. What happened?

mark

Please sign in to leave a comment.

16 comments

0
Avatar

Hi Mark, the applications that use the save method works normally.
Can you check if, on your code, the onSave callback is triggered correctly with the standard save button?

Guillermo Padilla 0 votes
Comment actions Permalink
0
Avatar

It isn't working when the save button is pressed. saveAsTemplate works as expected. Save is still broken

mark 0 votes
Comment actions Permalink
0
Avatar

We've invested a significant amount of time in building our own templates. Could that be the cause? The load in the editor, but maybe they can't be rendered somehow. Would you like me to send you one of our templates?

mark 0 votes
Comment actions Permalink
0
Avatar

The preview works?
(it also uses the nlparser to export the HTML)

Guillermo Padilla 0 votes
Comment actions Permalink
0
Avatar

I just checked the editor with one of your templates. Same error. Maybe it an ssl related issue?

mark 0 votes
Comment actions Permalink
0
Avatar

I take that back. the preview on your template seems to work. and so does the native save button

mark 0 votes
Comment actions Permalink
0
Avatar

and so does the save method! did you just change something on your end?

mark 0 votes
Comment actions Permalink
0
Avatar

But the preview on my templates is broken and the save method doesn't work. hmm

mark 0 votes
Comment actions Permalink
0
Avatar

Yea so it definitely seems like the issue is my template. I narrowed the problem down to the logo at the top. I'll keep working on it until I get the bottom of the issue. Thanks for working with me. I'm trying to finally ship this thing already

mark 0 votes
Comment actions Permalink
0
Avatar

And to answer your question, I built the template in your editor and then added some variables that I render into it server side. I basically made a template of the template your editor uses.

Just a side note: this type of support convo would be 10x more awesome in intercom.io (not a paid endorsement, just a true fact)

mark 0 votes
Comment actions Permalink
0
Avatar

Found the bug: the image property needed an empty href tag. Sorry for all the fuss. Thanks again for make this thing!

mark 0 votes
Comment actions Permalink
0
Avatar

can I access the https://rsrc.getbee.io/api/nlparser?isPreview=false endpoint myself to render a preview?

mark 0 votes
Comment actions Permalink